403 Forbidden using certain features

Discussion in 'Free Hosting' started by Jessica.C, Jan 9, 2015.

  1. Jessica.C

    Jessica.C Member Prime Account

    Messages:
    379
    Likes Received:
    5
    Trophy Points:
    18
    I have a knowledge base mod installed on my site, and up until today I have had no issues with adding or editing articles.......but now, all of the sudden, I cannot do either. I have already posted in the mod's support topic on the phpBB community site in case it is the modification itself.

    Anyways, when I try editing or adding a new article, I get this error message:
    Forbidden
    You don't have permission to access /phpBB3/kb.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    I checked the file permission and it's at 744...


    I am also getting it on certain pages on another site that does not have this mod. So it has to be x10, right?
     
    Last edited: Jan 9, 2015
  2. Jessica.C

    Jessica.C Member Prime Account

    Messages:
    379
    Likes Received:
    5
    Trophy Points:
    18
    Still getting this error. What is going on?
     
  3. leafypiggy

    leafypiggy Manager of Pens and Office Supplies Staff Member

    Messages:
    3,819
    Likes Received:
    163
    Trophy Points:
    63
    What is the content of the KB article you are trying to post?

    I'm seeing that it is being blocked by mod_security due to a potential XSS (cross site-scriting) attack.
     
  4. Jessica.C

    Jessica.C Member Prime Account

    Messages:
    379
    Likes Received:
    5
    Trophy Points:
    18
    It's just a little snippet (not created by me; I have linked to the topic by the person who did create it)
    It's not only happening when posting new articles though. I get it when EDITING them too - and the edits I'm trying to submit are very minor. I also get them on another site I own (subdomain of my main site). That site uses phpBB 3.1.2, and I have installed an extension called "Upload extensions". One of its features is that I can directly upload an extension that has been validated (there is a dropdown). However, when I choose one, then press "Upload". I get the 403 error - which is nearly identical to the error I posted in my first post, except it says "You don't have permission to access /ascraeus/adm/index.php on this server."


    EDIT: Okay I think you may be right...I tried adding a nonsense article that just had some random nonsense typed into it and it submitted. Dang :(
     
  5. Jessica.C

    Jessica.C Member Prime Account

    Messages:
    379
    Likes Received:
    5
    Trophy Points:
    18
    Can someone turn off mod_security on my account? It seems like this is the reason I'm getting the error all of the sudden
     
  6. Ohso

    Ohso Member Prime Account

    Messages:
    114
    Likes Received:
    4
    Trophy Points:
    18
    I thought Prime Accounts could turn mod_security off?


    also really, I'm asking because I would like to know if it's possible to disable it with prime account.
     
  7. bdistler

    bdistler Well-Known Member Prime Account

    Messages:
    3,534
    Likes Received:
    196
    Trophy Points:
    63
    when you upgrade a basic free-hosting account to "Prime" it is on the same free-hosting server (same place as it was)
    YOU can not turn mod_security off - on any free-hosting server
     
    • Informative Informative x 1

Share This Page