404 Error on page that already exists

Discussion in 'Free Hosting' started by tsnetwor, Feb 23, 2016.

  1. tsnetwor

    tsnetwor Member

    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    18
    To clarify, we all use oxwall. We've contacted oxwall support, but with no luck. We were told that this is a server-related problem. Mod_rewrite is not configured correctly. @Dead-i, is there a solution. Is there a way you can check our mod_rewrite is configured properly?
     
  2. tsnetwor

    tsnetwor Member

    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    18
    ISSUE SUMMARY:
    To clarify, we all use oxwall. We've contacted oxwall support, but with no luck. We were told that this is a server-related problem. Mod_rewrite is not configured correctly. @@Dead-i, is there a solution. Is there a way you can check our mod_rewrite is configured properly? If there's something wrong with mod_rewrite, can you please fix it for us. If not, we're out of luck. ;)
     
  3. tsnetwor

    tsnetwor Member

    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    18
    ISSUE SUMMARY:
    To clarify, we all use oxwall. We've contacted oxwall support, but with no luck. We were told that this is a server-related problem. Mod_rewrite is not configured correctly. @Dead-i, is there a solution. Is there a way you can check our mod_rewrite is configured properly? If there's something wrong with mod_rewrite, can you please fix it for us. If not, we're out of luck. ;)
     
  4. tsnetwor

    tsnetwor Member

    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    18
    ISSUE SUMMARY:
    To clarify, we all use oxwall. We've contacted oxwall support, but with no luck. We were told that this is a server-related problem. Mod_rewrite is not configured correctly. @@Dead-i, is there a solution. Is there a way you can check our mod_rewrite is configured properly? If there's something wrong with mod_rewrite, can you please fix it for us. If not, we're out of luck. ;)
     
  5. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Mine is still down. Now the homepage opens and all the rest have 404 error, but the homepage looks so messed up from how it actually is it might as well be 404 error as well right now. @Dead-i I guess you're the guy who can fix this error? I tried reverting back to an old backup and then reverting back to the newest backup with no luck. Site still down :/
     
  6. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
    Hello everyone,

    Sorry for the trouble here; there were some recent changes to our web server's configuration, and this is causing some unusual problems with mod_rewrite. Higher staff are currently working on a solution, but in the meantime, you should be able to add the line "RewriteBase /" (assuming you are rewriting on the root of your domain) to your .htaccess file to fix the problem.

    Thank you,
     
  7. tsnetwor

    tsnetwor Member

    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    18
    @Dead-i, how long will it take for them to find a solution? Where do we insert "RewriteBase /"?
    [​IMG]
     
  8. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,511
    Likes Received:
    112
    Trophy Points:
    63
    It would go after 'RewriteEngine On'.
     
    • Like Like x 1
  9. csccox10

    csccox10 New Member

    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    3
    same problem here
     
  10. tanak.sources16

    tanak.sources16 New Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    what to do to correct the error 404 please ?
     
  11. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Were you able to get it working mate? I can't find where to add RewriteBase either...
     
  12. essellar

    essellar Community Advocate Community Support

    Messages:
    3,295
    Likes Received:
    227
    Trophy Points:
    63
    caftpx10 posted the answer above.
     
  13. tanak.sources16

    tanak.sources16 New Member

    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hello,
    Same issue.
    Thank you for you anwser tsnetwor
    On .htaccess, I had
    RewriteRule ^page.html$ index.php?id=mapage.php [L]
    and I corrected by
    RewriteRule ^page.html$ /index.php?id=mapage.php [L]

    I had to add "/" behind "index.php". Maybe the configuration of server has change yesterday.

    Now, my website run !
     
  14. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I tried this and it just gave me an internal server error
     
  15. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
    Hi,

    You had a malformed RewriteRule line in your .htaccess file. I fixed it for you.
     
    • Like Like x 1
  16. djalikx1

    djalikx1 New Member

    Messages:
    8
    Likes Received:
    1
    Trophy Points:
    3
    I am still having issues with my site.

    Service Unavailable
    The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    http://djalik.x10host.com/webtrees/
     
  17. mandrfot

    mandrfot New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I was having this error too (my whole site was giving a 404 error message), but I added the "rewritebase /" code after "rewriteEngine on" in the htaaccess file (just as caftpx10 and dead-I recommend above) and their solution did work for me. I figured I would post this confirmation, since I didn't see any responses that confirmed the recommended solution. Thanks!
     
  18. tsnetwor

    tsnetwor Member

    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    18
    I just checked your site a moment ago, and it's working.
     
  19. newsbuzz

    newsbuzz New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I tried the RewriteBase / solution provided above but all it does is produce 500 internal server error.
     
  20. newsbuzz

    newsbuzz New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I tried the RewriteBase / solution provided above but all it does is produce 500 internal server error.
     
  21. newsbuzz

    newsbuzz New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    this is what my htaccess looks like

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^(.*)$ public/$1 [L]

    </IfModule>
     

Share This Page