404 Error on page that already exists

Discussion in 'Free Hosting' started by tsnetwor, Feb 23, 2016.

  1. fcahouse

    fcahouse New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Oh hey, RewriteBase / worked, thanks!
     
    Last edited: Feb 25, 2016
  2. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I tried this and it just gave me an internal server error
    Thank you so much! Everything is working good as new again :)
     
  3. newsbuzz

    newsbuzz New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    yea I fixed my problem too. all is well again now :)
     
  4. newsbuzz

    newsbuzz New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    yea I fixed my problem too. all is well again now :)
     
  5. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I tried this and it just gave me an internal server error
    Thank you so much! Everything is working good as new again :)
     
  6. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    @essellar Now, whenever I publish it goes right back to the 404 error. I tried checking the HTA access file and the only thing I changed was updated an iTunes link. Anyway I can get the instructions how to fix this, it reverted right back to the error from before :/
     
  7. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    @essellar Now, whenever I publish it goes right back to the 404 error. I tried checking the HTA access file and the only thing I changed was updated an iTunes link. Anyway I can get the instructions how to fix this, it reverted right back to the error from before :/
     
  8. phoeni66

    phoeni66 New Member

    Messages:
    1
    Likes Received:
    1
    Trophy Points:
    1
    I have created a website for a unit on my creative media course I can still open it up in cPanel to make any edits but can't open it up in the domain as there is a 404 message on every page, I've tried countless times in trying to solve the problem but have got NO idea...can someone please help me? Thanks.

    Lewis.
     
    • Like Like x 1
  9. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
    Hi Lewis,

    Until the issue is fixed, you can add the line "RewriteBase /" to your .htaccess file to temporarily fix the issue.

    Thank you,
     
    • Like Like x 1
  10. justinm5

    justinm5 New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I've tried the fix for my .htaccess file but it doesn't seem to work. On the home page it's still just black and white text with messed up formatting. On the other pages I can see my background and some semblance of my formatting but it's still messed up.

    Maybe something else is messed up in my .htaccess file. Here it is:

    # Powered by x10Premium.com
    DirectoryIndex index.php index.cgi index.html
    ErrorDocument 401 "Unauthorized"
    ErrorDocument 403 "Forbidden"
    RewriteEngine On
    RewriteBase /
    #### PERSISTENT CONTENT ####



    #### PERSISTENT CONTENT END ####

    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ sitepro/$1 [L,QSA]


    #### PERSISTENT CONTENT ####

    *Edit* nevermind, seems to be working now, my bad
     
  11. tsnetwor

    tsnetwor Member

    Messages:
    105
    Likes Received:
    2
    Trophy Points:
    18
    Hello. If you have a premium account, then you should login into your hosting panel and open a support ticket from there. Unless, I'm mistaken, which you should let me know.
     
  12. lipstic3

    lipstic3 New Member

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    lipstickandhighheels.x10host.com new site I created and same problem as my old one..could someone please help and fix this 404 issue or whatever it is thanks
     
  13. lipstic3

    lipstic3 New Member

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
     
  14. lipstic3

    lipstic3 New Member

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
     
  15. lipstic3

    lipstic3 New Member

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    how do you fix it? I know nothing about it. I wish someone from the server could fix my pages
     
  16. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hey mate, I saw no one addressed your question so hopefully I can help since I had the same problem. After you login to your account, go to your file manager. Then where you have your server installed you want to right click on the file that says htaccess and select edit code. That is where you add the line "RewriteBase /"

    You just add it right under where it says "RewriteEngine On" and then save the file
     
    • Useful Useful x 1
  17. lipstic3

    lipstic3 New Member

    Messages:
    6
    Likes Received:
    1
    Trophy Points:
    3
    THANK YOU so much smiles..it worked !!!
     
    • Like Like x 1
  18. growtho2

    growtho2 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Great! Happy I can help :)
     

Share This Page