500 Error

Discussion in 'Free Hosting' started by matttt2295, Aug 21, 2011.

Thread Status:
Not open for further replies.
  1. matttt2295

    matttt2295 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hello,
    I have installed Gallery 3 via the Softaculous and by doing it my self. And everytime i try to connect to the Gallery main pages, it gives me this.

    500 Error

    An internal server error has occurred. Please try your request again momentarily.

    • File or directory permissions are set too high: Files should be 0644, directories 0755.
    • Problem with your .htaccess file.
    • A syntax error in a CGI script.

    I have searched around and was talking about problems involving the .htaccess file but I have tried most of the solutions and none worked. One solution stated that I would have to have access to some of the Apache config files, but obviously I do not. It said I should contact my host to see if you can do this, or help me with the problem.

    I get an error 500 when I visit my Gallery 3 install for the first time

    This probably means that your webserver doesn't support the "php_flag" command in the .htaccess file provided with Gallery 3. Solutions are:

    1. edit your php.ini file and set "short_open_tag" to 1
    2. edit your apache configuration file to allow per-directory overriding of Options or All (note that this has implications to broad to discuss here):
    <Location "/gallery3/"> AllowOverride +Options </Location> Thank You

    P.S. It says I have reached the MySQL database limit, and yet on cPanel it says i have 2/4. Do we get 2 or 4 MySQL databases?
     
  2. CWeb Creative

    CWeb Creative New Member

    Messages:
    321
    Likes Received:
    6
    Trophy Points:
    0
    You only get 2 databases and php flags cant be set in htaccess or a 500 error will occur
     
  3. matttt2295

    matttt2295 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Ok, so I edited my php.ini file and set "short_open_tag" to 1 500 Error
    I edited my php.ini file and set "short_open_tag" to on 500 Error
    I deleted the .htaccess in the gallery folder completely 500 Error
    I deleted all of the php flags in the .htaccess file 500 Error

    Any Ideas?
    Thanks
     
  4. Corey

    Corey I Break Things Staff Member

    Messages:
    34,552
    Likes Received:
    183
    Trophy Points:
    63
    Please link to the issue.
     
  5. matttt2295

    matttt2295 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
Thread Status:
Not open for further replies.

Share This Page