500 internal server errors

Discussion in 'Free Hosting' started by r4cerbhoy, Jun 30, 2010.

Thread Status:
Not open for further replies.
  1. r4cerbhoy

    r4cerbhoy New Member

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    I'm On Fris and i keep receiving this screen everytime i try to access my site and cpanel Could you please help me
     
  2. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    To correct the 500 errors:

    1. Make sure any .php file has permissions set to 0755 or 0644. You will get 500 errors if they are set to 0777 or 0666.

    2. If 1) does not fix the problem, check any .htaccess files. If it has a line that starts with

    RewriteRule

    make sure that you have the line

    RewriteBase /

    at the top of the file.

    3. If problems persist, post back here with what you tried and other information.
     
  3. r4cerbhoy

    r4cerbhoy New Member

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    hi there i have had a look at those files and they all appear to have all the properties you replied with ie 0644 and 0755 and the .htaccess file appears fine is there anything else u suggest ?

    many kind regards
    dean
     
  4. dlukin

    dlukin New Member

    Messages:
    427
    Likes Received:
    25
    Trophy Points:
    0
    You can look at the Error Log from cPanel (not error_log file). That sometimes gives information.

    You can try posting the contents of .htaccess here.

    Lastly, do you get a 500 error if you just try to access a .html or .txt or image file? (ie, is it just on one type of file?)
     
  5. r4cerbhoy

    r4cerbhoy New Member

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    hi there i now i can't logon to cpanel to access these files can you help
     
  6. r4cerbhoy

    r4cerbhoy New Member

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    HTACCESS CONTENTS

    # -FrontPage-

    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*

    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName deanscomprepair.x10hosting.com
    AuthUserFile /home/dcr/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/dcr/public_html/_vti_pvt/service.grpRewriteCond %{HTTP_REFERER} !^http://deanscomputers.co.cc/.*$ [NC]
     
  7. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    If that is all one line, that is possibly the problem.
    Try renaming .htaccess to .htaccessBAK and see if you can access your site.
     
  8. cursed

    cursed New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    Sorry!! Post deleted!
     
    Last edited: Jul 5, 2010
  9. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    cursed: Do not hijack other people's threads. You will not get a reply here.
     
  10. r4cerbhoy

    r4cerbhoy New Member

    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    0
    fixed it it was the frontpage extensions nedded uninstalled then reinstalled thanks guys
     
Thread Status:
Not open for further replies.

Share This Page