503 Service Unavailable - SMF SMTP

Discussion in 'Free Hosting' started by narusimu, Jul 12, 2013.

Thread Status:
Not open for further replies.
  1. narusimu

    narusimu New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I have a serious problem. What I'm about to describe happened out of the blue, it used to work fine before. One of my users reported to me that he had problems registering on the forum, so I checked it out.

    Whenever the forum tries to send an email in any form (e.g. for registrations or just simply sending emails to other members through the forum) x10hosting's webserver gives an instant 503 Service Unavailable error. My forum is powered by SMF 2.0.4 and it uses SMTP (with PHP) for sending emails. About a month ago that configuration worked perfect, just the way it should. Now out of the blue, my forum can't send emails anymore.

    The logical explanation would be x10hosting having changed their PHP configuration in a way that mails cannot be sent with SMTP anymore, however that logic does not go in this case. The reason to that conclusion is as following. I have a website aswell, it's powered by Joomla. The website was launched at the same day the forum was and it used a similar configuration. It was also configured to use SMTP (with PHP) for sending emails. That configuration worked fine at the time, just as it did for the forum at the time. But here comes the weird part, the website can still perfectly send emails by using that same configuration (SMTP with PHP).

    So how is that possible? A month ago SMTP with PHP worked perfect for the website and the forum. Now it only works for the website. I didn't do any upgrades to the forum. The moment I try to send an email with the forum, the 503 instantly shows up, like it doesn't even try to use any resources. Now I'm wondering what changes x10hosting did to cause something like this, by knowing that I might be able to adjust the forum's code to work with this new configuration.The 503 says that "The server is temporarily busy, try again later!" but obviously that's not true.

    So if anyone knows what's going on, please help me out of my misery.
     
Thread Status:
Not open for further replies.

Share This Page