Access denied for user 'foro_final'@'localhost' (using password: YES) [1045]

Discussion in 'Free Hosting' started by tstfrx1, Oct 4, 2015.

  1. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    General Error
    SQL ERROR [ mysql4 ]

    Access denied for user 'foro_final'@'localhost' (using password: YES) [1045]

    An sql error occurred while fetching this page. Please contact an administrator if this problem persists.


    How can be solved this? It is been a while and I have no idea. Would like to receive some help. Thank you.
     
  2. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
    Hi,

    The MySQL user "foro_final" does not exist. Please create your user from the "Databases" section of cPanel, and then change your phpBB configuration accordingly. :)

    Thank you,
     
  3. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi, thank you for your help.
    The config file is updated with the database I created here. The problem I think it is that "foro_final" is the name of the database I created on Xampp server. But I don't understand why it is still there and it doesn't refresh.
     
  4. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Any advice please?
    Thank you.
     
  5. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,500
    Likes Received:
    108
    Trophy Points:
    63
    Have you got a MySQL user set up and linked to the database?
     
  6. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Yes, sure. Thank you.
     
  7. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I don't know why it shows the user from the previous database (xampp).
     
    Last edited: Oct 5, 2015
  8. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,500
    Likes Received:
    108
    Trophy Points:
    63
    On X10, make sure the MySQL user is 'foro_final' (assuming that's what you're wanting).
     
  9. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    But is conditioned to start like this: "tstfrx1_" right?
     
  10. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,500
    Likes Received:
    108
    Trophy Points:
    63
    If it has that prefix then add it to the beginning of the user name in the config file.
    TBH, I haven't used X10 for quite a while so it's not a surprise to me that I wasn't aware. Haha.
     
  11. Anna

    Anna I am just me Staff Member

    Messages:
    8,405
    Likes Received:
    241
    Trophy Points:
    63
    if you migrated files from another server, you would need to clear off some files from the /phpBBroot/cache folder (make sure to not delete index.htm and .htaccess).
     
    • Like Like x 1
  12. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Yes, it is already there. But for that reason i cannot rename it "foro_final". Thanks.
     
  13. tstfrx1

    tstfrx1 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Yes! that was it. Thank you very much!
     
    Last edited: Oct 5, 2015

Share This Page