Resolved Can't access my Cpanel or any back-end

Discussion in 'Free Hosting' started by josephincharge54, May 26, 2020.

  1. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8
  2. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8
    my site https://cenci.cf/ is failing to connect to database. Presumably due to a similar migration/retirement of the illuminated service.

    I look forward to your reply.
     
  3. Anna

    Anna I am just me Staff Member

    Messages:
    10,389
    Likes Received:
    440
    Trophy Points:
    83
    Since the forum account is not linked with any hosting, and you using cloudflare so I can not check what server your a that way either, could you please tell me under what hosting username, or email address the account is setup? If you do not want to put it publicly you can PM me.
     
    • Like Like x 1
  4. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8
    Many thanks Anna! I have sent you a PM :)
     
  5. Anna

    Anna I am just me Staff Member

    Messages:
    10,389
    Likes Received:
    440
    Trophy Points:
    83
    I have seen the PM, you should now be able to properly login to the account.

    The main problem was that in our manual purge back in early March the account itself was removed as being inactive as there had been no login during the 60 days prior to the cleanout being done.

    It is in fact rather strange that the site has worked at all aside from the database issue as the Illuminated server (which I'm guessing the domain pointed to) should be decommissioned completely since a while back.

    However, in case you haven't done so yet you would need to update the A record at cloudflare as you are now moved to a different server (x14.x10hosting.com), the IP for that server is: 198.91.81.14

    Also due to Illuminated being removed as a service (it has not been offered for a few years now and as far as I understood there would be no active subscriptions that had paid in the last few years), your account would now be considered a normal free hosting account (though with some perks kept such as the extra databases) which means that you will need to login at least once every 30 days.
     
    • Like Like x 1
  6. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8
    Many thanks Anna! I can confirm that I am able to log in normally now! Will update the A record and server IP address accordingly :)
     
  7. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8

    Hi Anna,

    I tried updating the A record to 198.91.81.14, after which i receive an Error 500:

    This page isn’t workingcenci.cf is currently unable to handle this request.
    HTTP ERROR 500​

    When i set the A record back to 162.253.224.37 I get the following error message (but Wordpress)

    Error establishing a database connection​

    It is almost as if my database has been migrated, but my site remain hosted on 162.253.224.37.

    Can you kindly take a look why?

    Many thanks,
    Joseph
     
  8. garrettroyce

    garrettroyce Community Support Community Support

    Messages:
    4,862
    Likes Received:
    169
    Trophy Points:
    63
    The database must be "localhost" or "127.0.0.1". Anything else will not work. I believe that outgoing SQL is also blocked.

    Since you are using Cloudflare, make sure they have the A record 198.91.81.14. Once you do that, clear your browser cache, clear your DNS cache, and try again. If you get an error, you need to wait 24-72 hours for the DNS to change due to nature of the DNS system being kind of slow at times.

    [edit]
    Moved to free hosting support forum so you get better visibility.
     
  9. Anna

    Anna I am just me Staff Member

    Messages:
    10,389
    Likes Received:
    440
    Trophy Points:
    83
    We can not help troubleshoot if you have the domain pointed to the wrong server. It has to point to 198.91.81.14

    The error log may hold clues to what causes the error 500, a common reason however is mismatched php version (on the new servers php version 7.2 is default). Older scripts, that use the depreceted mysql extension will not work under that version (the mysql extension was removed with php 7.0 and replaced with PDO_mysql and mysqli).

    You are able to set php version 5.6 which allows for the mysql extension, however this is way past its end of life and should not be used long term.
     
  10. garrettroyce

    garrettroyce Community Support Community Support

    Messages:
    4,862
    Likes Received:
    169
    Trophy Points:
    63
    @josephincharge54 Have you made any progress on this issue? Please let us know if you need any further assistance or this thread will be closed for inactivity. Thank you.
     
  11. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8
    Hi Anna and Garrett,

    Many thanks for following up. I was waiting for the DNS propagation to complete over the past days. Oddly enough, it seems that I am still unable to access my site (cenci.cf, the error code is 500).

    Please kindly see below the settings that I currently have on Cloudflare, as per your instruction.

    Can you kindly let me know what might be missing from my config?

    Yours Sincerely,
    Joseph

    upload_2020-6-9_9-41-12.png
     
  12. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8
    With regard to Anna's point on deprecated mysql extension, I am not entirely sure what to do with that - the sql database I use is directly hosted on x10hosting too (created from cpanel/sql myphpadmin). For clarification, I can access the database with no issues from the cpanel.

    If this helps with your trouble-shooting my site (which is deeply appreciated) my website (a simple wordpress site) displays error 500 when pointed to 198.91.81.14

    upload_2020-6-9_9-48-14.png

    and it display the following error message when pointed to 162.253.224.37
    upload_2020-6-9_9-46-59.png

    Many thanks in advance.

    Yours,
    Joseph
     
  13. garrettroyce

    garrettroyce Community Support Community Support

    Messages:
    4,862
    Likes Received:
    169
    Trophy Points:
    63
    You cannot see your site at 162.XXX.XXX.XXX

    Your site is now at 198.XXX.XXX.XXX

    These are two different servers, so they won't communicate.

    The 500 error will put some information in your log about what caused it. Please open DirectAdmin and check your error logs.
     
    • Like Like x 1
  14. josephincharge54

    josephincharge54 Member Prime Account

    Messages:
    35
    Likes Received:
    1
    Trophy Points:
    8
    Hi Garreth,

    Thank you so very much for pointing me in the right direction. I have found the culprit that disabled my site (a safety plugin that blocks access to the site due to migration). I have my site up and running again.

    Best wishes,
    Joseph
     
  15. garrettroyce

    garrettroyce Community Support Community Support

    Messages:
    4,862
    Likes Received:
    169
    Trophy Points:
    63
    Glad to help. Please let us know if anything comes up.
     

Share This Page