Connection to database Lost error 500

Discussion in 'Free Hosting' started by eliteel5, Apr 29, 2021.

  1. eliteel5

    eliteel5 New Member

    Messages:
    27
    Likes Received:
    1
    Trophy Points:
    3
    Good evening all

    This was all working beautifully then suddenly this screen showed after deleting a relationship

    I tried deleting the database and recreating this but no joy

    Its been working fine all day Why this should happen now I do not know

    Could someone check this for me

    error.png


    Thanking you

    Mark
     
  2. spacresx

    spacresx Active Member

    Messages:
    969
    Likes Received:
    70
    Trophy Points:
    28
    Generally x10hosting support does not include help with custom scripts.
    it is up to you to make sure your script follows the T.O.S

    there are a number of reasons for such errors.
    usually being server permissions or rejections.
    the error displayed is self explanatory.
    and suggests what to look for.

    another option is to do a google search for "mysql error 500"
    to get information and possible fixes for that error.
     
    • Like Like x 1
  3. eliteel5

    eliteel5 New Member

    Messages:
    27
    Likes Received:
    1
    Trophy Points:
    3
    Hi spacerx

    So that you remain updated for some reason this has rectified itself
    After deleting the database with which I only use dedicated scripts that I follow from tutorials


    Ref this page @ present


    I do take absolute notice of T.O.C and knowing that you have strict criteria not that I am that way inclined anyway

    I'm not save that of if I wish to express an issue which I know is problematic or where some one deliberately lies to me then I take appropriate action using external dedicated organisations , legally approved bodies to suitably investigate in full

    However be assured whilst I am a very firm believer in free speech I am not the type of person who is interested in other persons private data unless that data has been used illegally and against persons such as myself for which they have no permissions to do so and I'm sure you will also agree (I'm entitled just as everyone else to have the right to self defence under these circumstances )

    In other words and for example informations used to bully , harass , demand ransoms , throw accusations which are unfounded , using such data to instigate viscous assaults, instigate acts of terrorism etc

    I dont agree with how some other social websites are run which do allow adult content yet remove any remarks , placed about such , and allow for some reason part of their users to do what ever they want , whilst others not and I dont like the current founder of Facebook at all I think he's a total joke completely out of place whilst they seem to feel that are somewhat untouchable even by law inclusive his supposed team of community standards who are equally a complete and utter joke

    Or as second example ::

    When you do need to make comment on real issues then they not only remove these but also remove educational links and I have had instances in many of the above forms and more on more than just one occasion with the likes of these platforms and this includes the general consensus by many persons at all levels

    One of the reasons I joined X10 to be frank , also one of the main reasons why I am inviting professionals to join this site knowing that their skills and teachings will be of tremendous aid to X10 and others

    People whom I hold a great deal of respect for and whom I talk to on regular basis about many a subject which is highly technical and extremely advanced in many different areas of both technologies and trade

    I have also at the same time done as you suggested with your advice and always have time to listen to others when I know full well they know more than me

    The informations I found as per your suggestion were as as follows obtainable from this link

    This suggests the following not that this is an issue as this is now back up and running

    1. Missing dependency modules

    PhpMyAdmin utility depends largely on certain PHP modules like php-mbstring, php-gettext, etc. Unfortunately, these modules do not come across with many standard PHP packages.

    When doing a fresh installation of PhpMyAdmin, the setup will create all the required PhpMyAdmin files. But, if these related modules are missing on the server, accessing PhpMyAdmin reports “500 Internal Server Error” status code. At times, it can be even a blank page.



    2. Wrong permissions

    Similarly, wrong permissions of php files can also be a reason for PhpMyAdmin errors. For example, in cPanel servers, wrong permission on the files like /usr/local/cpanel/3rdparty/bin/php, /usr/local/cpanel/3rdparty/bin/php-cgi create problems with PhpMyAdmin. Any permission other than 755 will cause PhpMyAdmin to stop working.



    3. PHP configuration limits

    Yet another common reason for internal server error in PhpMyAdmin can be PHP limits set in the server. For security reasons, PHP limits the maximum resources a PHP process can use on the server. If any process cross these limits like memory_limit, max_input_vars, etc. it results in the error as shown.

    Well all three suggestions to so far are completely out of my hands altogether and could only be done , rectified by administrators

    My thoughts as this stage were I wonder if its an update ?

    X10 backing up @ present or doing work of some description , answer , "Possible "

    Has there been perhaps media storage failure as this not unknown , nothing is infallible or that prefect now matter what people suggest or how educated they are This can be due to hardware issues , bad sectors on drives We all know this where re-installing wont solve the issues and leads to must have hardware upgrades These bios reports will report when degradation of media storage begins or some bios on more modern servers will , not all though

    Has X10 been hacked ?

    Also possible and quite common these days which I'm sure no one thinks clever and that includes myself unless done for legitimate reasons in which case legally in the UK although they will never tell you this they typically have to advise of such and issue reasons for doing so and additionally have to consort with legal bodies In other words they are obliged by law to seek the permission of a formerly appointed Judge in an proved court of law to do so

    How ever what I did notice which may be a pointer was phpMyadmin is , or at the time of use was reporting that new version is now available


    I also considered this might be the reason this may have happened as well, possible bug perhaps

    Having had many years of experience in the communications Industry which is really simply now a change from analogue transmission across twisted pair now data transmission across fibre optic , via routers switches etc I take this into account as well

    I'm only to aware of what does happen and quite often with all the pointing fingers , blaming each other for something which will never ever be prefect anyway and 9/10 is never who they point at by any means of the imagination

    I trust that settles your position and mind somewhat knowing I am only to aware of the pressures that people such as yourselves are placed under in this industry

    Never mind the rows and arguments that some cause both clients and system management wise with never mind the politics within this with persona thinking all should be perfect , never fail when it never ever will be otherwise we would never need to update would we ?

    All scripts that I write I test on my own server locally on an internal network to ensure to the best of my ability that they are running correctly and do work before attempting live server implementation across connections via lan , wan

    Possible Suggestion for perhaps consideration ::

    It would be good if there were support teams to assist with coding or suggest there are better ways of doing this as this encourages people and to learn correct approaches

    To conclude today , every suggestion you have made has worked amazingly and your advice has been excellent , I have no complaints to date and am very impressed with X10 thus far

    I can only think there must be external reasons for this happening as all was done using the dedicated ERD designer within phpmyadmin and which after deleting the link through the designer was when the issue appeared

    On mine when I do this as I also use phpmyadmin on my own local Apache web-server then this will report , " cannot unlink table" , for what ever reason so that you know that you have to delete the master table or empty all records with foreign links back to the master table then it will allow link deletion or empty the child table

    I have no idea as why or what went wrong but all worked extremely well up to the last one or two hours

    Bit of a mystery this , typically although not knowing exactly how your servers are setup i would think they may have a reporting , logging facility which holds records of transactions which might provide clues

    Hopefully from this feedback some may be able to pinpoint what did go wrong and throw possible light on this but it is all now working



    I hope my feedback is of use to you

    Once again thanking you for your concerns and advice issued

    Mark
     
    Last edited: Apr 29, 2021
  4. eliteel5

    eliteel5 New Member

    Messages:
    27
    Likes Received:
    1
    Trophy Points:
    3
    As explained in previous reply all working

    I have made changes to code again but since I'm only creating tables at present then there should be no issues

    What I have done is taken screen shots which you can see below to show now all working plus pre mentioned responsibilities of general failure today

    The first issue was no privileges granted so I went into table creation using the web oriented text field creation for table and created a table and the columns with this

    Screenshot_3.png

    After doing this you are then presented with view sql so to see where I may have made mistakes myself I then copied the sql and then pasted this into the sql text editor then run the statement

    Incredible from no permissions granted suddenly went to permissions granted with table created and fields

    Having done this I logged out deleted the database from CPanel and recreated again

    Obviously I cannot grant permissions on the database as this is admin that can do this or automated script which must do this for you and that can only be done server side administration

    Next I double checked version of phpmysqladmin

    Screenshot_4.png

    What Ive done is striped the message advising you that phpmysqladmin has been superseded with version 5.10 and suggestive that you should upgrade

    Following this I then manually entered code as before and low and behold relationship correct , coding correct , fields and table construction correct , and also within the visual ERD within phpmysqladmin

    Apart from not using the ` ` signs with database names , column names I couldn't see what else I may have done wrong if at all so I'm as perplexed as anyone else might be as to what went wrong

    Good news is this is now working as expected thus far
    Hold thumbs and hope for the best

    This is why I work locally in the first instance to get this running for which I either use direct sql from mysql prompt plus this provides backup should all fail server side

    Screenshot_5.png

    Locally I use a open-source package known as DBeaver which is excellent for talking to maria-db

    This is open-source as well by the way and very good it is too
    Link here for this but word of advice ... If you are to download this then use the zip version if you happen to be using OpenSUSE which I am as the RPM wont install correctly as I found out the hard way

    Also make sure you have correct Java version as well as architecture selected for your machine

    This uses the java-mariadb connector to talk to maria-db whilst still using sql commands as you would with lets say with netbeans only with this you would interchange JDBC Connector with maria-db java connector

    Link here and here for anyone's interest who might be watching this post

    The relevant driver you need to download from here for mariadb

    Back to some of this over the weekend hopefully


    Until then :);)
     
    Last edited: Apr 29, 2021

Share This Page