Error establishing a database connection

Discussion in 'Off Topic' started by heknowsy, Jan 2, 2020.

  1. heknowsy

    heknowsy New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have had my site for 4 years. Occasionally, my blog website becomes unresponsive, but it only last a couple of hours. On New Years Day, at 12:15 a.m. my blog website became unresponsive. Every time I try to access it, I get the message:
    Error establishing a database connection

    It is still unresponsive.

    Someone, please help me!


    Thank you,

    Michelle
     
  2. coolshow

    coolshow New Member

    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    Hi There. I have the same problem. it seems like the database have been removed or just vanished :/
    Please help! the website is :
    http://coolshows.x10host.com/
     
  3. fannibc2

    fannibc2 New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I got the same error. The only thing I can see is "Apache is functioning normally". Could you please kindly advise?

    My website address is www.fannibc.com
     
  4. Anna

    Anna I am just me Staff Member

    Messages:
    9,681
    Likes Received:
    358
    Trophy Points:
    83
    As for the database issue as per the two first posts, we noticed a bunch of databases didn't transfer properly to x15, we're working on that, though for some accounts that means a retransfer is needed. During this failure to login may occur so it is adviced to not attempt it until your domain resolves properly (apache functioning normally would for users on x15 be one indicator the account is affected).

    As for the last post, your issue is unrelated to the above, but rather experiencing an issue with apache causing domains with a forced redirect to https to fail if there isn't a proper certificate. If you have such redirect in a .htaccess you would need to remove it, if it is through setting in a script you run editing the database may be the only option, please consult script support for that if you are unfamiliar with editing the database. We are looking at a workaround for the issue, but I can't say with certainty how long it could take to sort out.
     
  5. fannibc2

    fannibc2 New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for your prompt reply. Actually last time around 10 days ago the site was up and running. I have not changed, or added any content or redirected the website since that day, but it has not worked since past Monday. I also checked the DirectAdmin/Site Redirection and there is nothing there. Do you think the only way is still to edit the database/htaaccess?
     

Share This Page