FTP problems

Discussion in 'Free Hosting' started by encryp21, Jul 9, 2018.

  1. encryp21

    encryp21 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Any file I upload or modify using my FTP client results in blank 0-byte files. I am unable to manage my website via FTP due to this issue, because nothing gets uploaded aside from the filename.

    If I upload index.php (1KB) it ends up as index.php (0B).

    I have used x10hosting years ago with this same FTP client and have had no issues, and still use this client for premium hosting from another provider with no issues.

    This isn't really a technical support issue but rather to inform that FTP is not functioning properly. I already emailed x10hosting and they told me to come to the forum....
     
  2. lylex10h

    lylex10h Active Member

    Messages:
    750
    Likes Received:
    47
    Trophy Points:
    28
    FTP is functioning properly. I was able to successfully upload a file using FileZilla with the following settigns in the Site Manager:
    Protocol: FTP - File Transfer Protocol
    Host: xo#.x10hosting.com
    Encryption: Require explicit FTP over TLS
    Logon Type: Normal
    User: cPanel User
    Password: cPanel Password

    Check in cPanel to make sure you are not out disk space.
     
  3. encryp21

    encryp21 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have plenty of space because I just created the account. I can edit files via File Manager, but anything through FTP becomes blank.

    I am able to login to FTP using the information you described above (as shown under quick FTP on client login page), but I cannot upload anything.

    Perhaps it is the specific server I am on? xo3.x10hosting.com

    I have tried other FTP clients without success as well.
     
  4. encryp21

    encryp21 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Okay so the issue was I had disabled "Passive Mode".

    The FTP won't let me connect with Passive Mode enabled. Once I disable it, I can connect but everything uploaded is blank.

    Oddly enough, Passive Mode works if I enable a SOCKS5 proxy prior to the FTP connection. Everything works afterwards.

    Odd why Passive Mode won't work on this server without a proxy.
     
  5. lylex10h

    lylex10h Active Member

    Messages:
    750
    Likes Received:
    47
    Trophy Points:
    28

Share This Page