Full server path name in URL

Discussion in 'Free Hosting' started by Owen Walter, Mar 13, 2018.

  1. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Basically when I click on any link in my homepage I'm redirected to "<domain>/home/<username>/public_html/<path>". This is basically a duplicate of this post that was ignored. Has anyone found a solution?
     
  2. lylex10h

    lylex10h Active Member

    Messages:
    799
    Likes Received:
    54
    Trophy Points:
    28
    Please create a .htm file with the following code in your account and provide a link to that file.
    HTML:
    <html>
    <body>
    <a href="https://x10hosting.com/">Link Test</a>
    </body>
    </html>
     
    • Like Like x 1
  3. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    owenw.x10host.com/link.htm
     
  4. lylex10h

    lylex10h Active Member

    Messages:
    799
    Likes Received:
    54
    Trophy Points:
    28
    • Like Like x 1
  5. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Sorry about that. I'm seeing this issue at my admin panel. I added more pages. Try clicking on the "Store" link
     
  6. lylex10h

    lylex10h Active Member

    Messages:
    799
    Likes Received:
    54
    Trophy Points:
    28
    I'm not familiar with Grav at all but my diagnosis is that you have /home/owenwx10/public_html/ some where in the config for it. Try changing this variable to /
     
  7. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I switched to Grav after having this same problem with Drupal. I think it's a server/apache config issue.

    EDIT: If it helps config is copied without modification from my local install.
     
  8. lylex10h

    lylex10h Active Member

    Messages:
    799
    Likes Received:
    54
    Trophy Points:
    28
    Try installing Drupal with Softaculous to something like http://owenw.x10host.com/Drupal-test and see if that works. I know WordPress doesn't have this issue with pretty permalinks so that's why I think it's a config issue.
     
  9. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Setup http://owenw.x10host.com/wp/ because Drupal doesn't support Clean URLs and it broke my Grav install.... but the issue is fixed for Wordpress.
     
  10. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    UPDATE: Fixed Grav. Issue is still present.
     
  11. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    UPDATE 2: Links to http://owenw.x10host.com/blog work but all the ones on the page are rewritten to that server path.
     
  12. Anna

    Anna I am just me Staff Member

    Messages:
    8,408
    Likes Received:
    242
    Trophy Points:
    63
    Check .htaccess and enable/add RewriteBase / (assuming the .htaccess is in the public_html root, if in a subfolder it would need to be like RewriteBase /subfolder/)

    Needs to go before any rewrite rules and after rewrite is turned on, many times the .htaccess that comes with a cms/forum and such have it already written in where it needs to be, but as a comment only as not all servers actually need it.
     
    • Useful Useful x 1
  13. Owen Walter

    Owen Walter New Member

    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    That worked! Thanks so much!
     

Share This Page