HTTP REMOTE_ADDR incorrectly set to host's own IP address

Discussion in 'Free Hosting' started by stovellx, Mar 9, 2016.

  1. stovellx

    stovellx New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My site is hosted on X01, and ever since 2016-03-08 at 7:00:00 GMT, the value of the REMOTE_ADDR header for all HTTP requests to my site has been set to 198.91.81.2. This is the IP address of X01 itself. Clearly, something is wrong in the Apache configuration on X01.
     
  2. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,530
    Likes Received:
    114
    Trophy Points:
    63
    Also affected on my end. Here's the information my script is returning:
    The third header has the actual information that isn't to do with X10. Yes there's two because I'm using a network that also uses a proxy at the moment.
     
    Last edited: Mar 9, 2016
  3. bdistler

    bdistler Well-Known Member Prime Account

    Messages:
    3,534
    Likes Received:
    196
    Trophy Points:
    63
    same on my free-hosting server xo3
     
  4. Bryon

    Bryon I Fix Things

    Messages:
    8,149
    Likes Received:
    101
    Trophy Points:
    48
    This problem has been fixed, it shouldn't be happening. If you notice the trouble recur please let us know right away.
     
  5. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,530
    Likes Received:
    114
    Trophy Points:
    63
    Issue is still around on xo2.
     
  6. Bryon

    Bryon I Fix Things

    Messages:
    8,149
    Likes Received:
    101
    Trophy Points:
    48
    Can you check again now? It looks like I forgot to apply the configuration change on the xo2 server.
     
    • Like Like x 1
  7. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,530
    Likes Received:
    114
    Trophy Points:
    63
    All good now. Thanks.
     
    • Like Like x 1
  8. Bryon

    Bryon I Fix Things

    Messages:
    8,149
    Likes Received:
    101
    Trophy Points:
    48
    Thank you for confirming that for me!
     
  9. stovellx

    stovellx New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Your fix worked for me, too. Thanks, Byron.
     

Share This Page