Impossible to disable the Varnish Cache.

Discussion in 'Free Hosting' started by lingeri3, Oct 27, 2016.

  1. lingeri3

    lingeri3 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I'm trying desperately to disable the Varnish Cache, so I followed the instructions found here:

    https://x10hosting.com/support/general/varnish-cache?from_search=13843420

    and I modified the .htaccess file in the /public_html/ folder accordingly:

    # $Id$
    #
    # This is used with Apache WebServers
    #
    # For this to work, you must include the parameter 'Options' to
    # the AllowOverride configuration
    #
    # Example:
    #
    # <Directory "/usr/local/apache/htdocs">
    # AllowOverride Options
    # </Directory>
    #
    # 'All' with also work. (This configuration is in the
    # apache/conf/httpd.conf file)

    # The following makes adjustments to the SSL protocol for Internet
    # Explorer browsers

    #<IfModule mod_setenvif.c>
    # <IfDefine SSL>
    # SetEnvIf User-Agent ".*MSIE.*" \
    # nokeepalive ssl-unclean-shutdown \
    # downgrade-1.0 force-response-1.0
    # </IfDefine>
    #</IfModule>

    # If Search Engine Friendly URLs do not work, try enabling the
    # following Apache configuration parameter

    # AcceptPathInfo On

    # Fix certain PHP values
    # (commented out by default to prevent errors occuring on certain
    # servers)

    # php_value session.use_trans_sid 0
    # php_value register_globals 1

    #Disable the Varnish Cache
    Header set Cache-Control "max-age=0, private, no-cache, no-store, must-revalidate"

    but it doesn't work: when I request a .css file I'm still getting this response header:

    Age: 1030
    Connection: keep-alive
    Content-Length: 343
    Content-Type: text/html; charset=iso-8859-1
    Date: Thu, 27 Oct 2016 12:33:55 GMT
    X-Cache: HIT
    X-Cache-Hits: 19
    X-Varnish: 25134032 25886859

    to the request header:

    Host: lingerie.x10.bz
    User-Agent: Mozilla/5.0 (Windows NT 6.1; rv:49.0) Gecko/20100101 Firefox/49.0
    Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
    Accept-Language: it-IT,it;q=0.8,en-US;q=0.5,en;q=0.3
    Accept-Encoding: gzip, deflate
    Referer: http://lingerie.x10.bz/custom/stylesheet/
    Connection: keep-alive
    Upgrade-Insecure-Requests: 1
    Cache-Control: max-age=0

    from the GET:
    http://lingerie.x10.bz/custom/stylesheet/home.css


    PLEASE HELP!!!
     
  2. essellar

    essellar Community Advocate Community Support

    Messages:
    3,295
    Likes Received:
    227
    Trophy Points:
    63
    Remember that requests have to go through Varnish, and it'll serve the cached version until that ages out. Once it requests a new copy from the server, that copy will have the no-cache header and will not be cached, but until then the old copy is cacheable.
     
  3. lingeri3

    lingeri3 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi essellar,

    it was exactly what happened: it took some time but now the all seems to work correctly.

    Thank you for your reply.
     

Share This Page