Layout problem with a template

Discussion in 'Review My Site' started by trailin2, May 26, 2015.

  1. trailin2

    trailin2 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Hi x10members,

    I'm still trying to figure out all this html/css stuff and should probably just use the x10hosting site editor but I want to learn a little :)

    I'm testing out a rss style template at trailingpdx.x10.mx/projects/fastfreddie and can't seem to get the page / columns to layout correctly when I resize the browser, everthing seems to shove left and display's horribly.

    If anybody has a few minutes to go have a look/review and give me maybe a few pointers on getting the layout to render correctly I'd appreciate it.

    update: oh and yes i know i'm using courier font i like it and this is a template design i'm using for personal self use.

    Thanks yo,
    Darren
    TrailingPDX.x10.mx 99785458.png 5468521.png
     
    Last edited: May 26, 2015
  2. essellar

    essellar Community Advocate Community Support

    Messages:
    3,295
    Likes Received:
    227
    Trophy Points:
    63
    It's just that the breakpoint is too severe. Either you have enough room for three columns, or you don't so you only get one. So, basically, either full-sized desktop (720p or better) or mobile; nothing in-between. Unfortunately, you seem to want to support IE8 - otherwise I'd tell you that flexbox is your friend, and front-end frameworks suck. (It's true regardless, but IE8 means that truth is irrelevant here.) You'd need at least one two-column media query to fix the problem with this structure. Or dump the framework, use max-width and auto margins on the container, and float the widgets.
     

Share This Page