In Progress "Missing a temporary folder" error

Discussion in 'Free Hosting' started by ifixtech, Jun 27, 2020 at 4:05 PM.

  1. ifixtech

    ifixtech New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi everyone,

    I've been trying to blast through this issue for many hours now but haven't seen to come up with a resolution for my "icapturevisuals" website. A little backstory: I was over my data quota (of 500Mb) and decided to delete the domain and softaculous WordPress installs to start from scratch. I readded the domain, fixed DNS records, and started a new install of WordPress using Softaculous (while DA is on PHP 7.2 native).

    But, I'm running into a problem where whenever I try to upload a file (be it a theme or media) I run into the "Missing a temporary folder" error. My error logs show: PHP Warning: File upload error - unable to create a temporary file in Unknown on line 0

    I have tried the fix of editing wp-config.php and adding the line:
    define('WP_TEMP_DIR', dirname(__FILE__) . '/wp-content/temp/');
    And created the temp folder with full permissions. I also verified permissions for the rest of the files/folders of the install. The other fix I've tried is creating a php.ini file to specify a tmp directory to no avail. I've tried almost every version of PHP, and sometimes that created new problems of losing the database connection despite correct database info/credentials. I suspect this is server-side and the true tmp folder (wherever it is) may not exist or doesn't have write permissions.

    Thanks in advance for any help.
     
  2. spacresx

    spacresx Active Member

    Messages:
    614
    Likes Received:
    34
    Trophy Points:
    28
    Any temp folders created should be in your public_html directory.
    server folders (below the public_html should never be touched)

    the actual path should be
    home/user/domains/domain-name/public_html or just
    root/domains/domain-name/public_html/

    that is where folders belong when you install scripts for your website.
    if you put them anywhere else the scripts would never find them.

    i assume it is an issue with the wordpress you try to install.
    but im not 100% sure as i dont use wordpress anyway.
    but id suggest downloading wordpress then installing,
    i wouldnt use softalicious for the install.
    but thats just my opinion.
     

Share This Page