PHP Issues - Any Server

Discussion in 'Free Hosting' started by Bryon, Jun 17, 2007.

Thread Status:
Not open for further replies.
  1. Livewire

    Livewire Abuse Compliance Officer Staff Member

    Messages:
    18,151
    Likes Received:
    214
    Trophy Points:
    63
    SMF's running fully for the moment on my server, so whatever you guys did fixed something (probably not all of it based on the replies, but it's definitely fixing it).

    Now I can log in and navigate without getting a blank page :)
     
  2. nightscream

    nightscream New Member

    Messages:
    948
    Likes Received:
    0
    Trophy Points:
    0
    mail() doesn't work anymore :s
    i tried to use mail() but i don't get a mail
    but no error at all
     
  3. batistablr

    batistablr New Member

    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    0
    how much longer until it's done?
     
  4. musoc

    musoc New Member

    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    Oh No!
    Yes, someone has fixed the putenv() problem but ever worse now I have this error message in my directory; http://musoc.exofire.net/chevalier
    The whole gallery is stilldown with error;

    Error
    Error (ERROR_PLATFORM_FAILURE) :

    * in modules/core/classes/GalleryTemplate.class at line 270 (GalleryCoreApi::error)
    * in modules/core/classes/GalleryTemplate.class at line 200 (GalleryTemplate::_initCompiledTemplateDir)
    * in main.php at line 418 (GalleryTemplate::fetch)
    * in main.php at line 87
    * in main.php at line 80
    * in /home/musoc/public_html/chevalier/main.php at line 3

    Can anyone please help? Perhaps an x10hosting Admin has changed something again on my server/membersettings? I haven't changed anything in 4 months and only yesterday I noticed the putenv() error and now that it's fixed; this error is here?

    Thanks so much guys and please help;
    I am utterly desperate...
    Tom :)
     
  5. Timhortons

    Timhortons New Member

    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    0
    In the SMF packages screen where you can apply modifications to the forum, I'm getting this:

    An Error Has Occurred!
    Sorry, your PHP configuration doesn't have support for zlib. Without this, the package manager cannot function. Please contact your host about this for more information.

    If you could fix it, that'd be great. :)

    I'd also like to report that my SMF has been running pretty smoothly since you made those fixes, thanks very much :) This is the only other problem that I've had.
     
    Last edited: Jun 21, 2007
  6. Livewire

    Livewire Abuse Compliance Officer Staff Member

    Messages:
    18,151
    Likes Received:
    214
    Trophy Points:
    63
    Seconded on both accounts (broken packages area, which I just found out about after reading your post, and the fact that otherwise it seems to be working quite nicely). Guess its not totally fixed yet, but its definitely on the way :)
     
  7. LyteNight

    LyteNight New Member

    Messages:
    126
    Likes Received:
    0
    Trophy Points:
    0
    Can you enable Short Tags? Thanks :D.
     
  8. cyberxzt

    cyberxzt Zine Tech

    Messages:
    798
    Likes Received:
    0
    Trophy Points:
    0
    my website just turned into a blank page zine-tech.com

    its e107

    nvm i just found out my isp is acting like crap again.
     
    Last edited: Jun 21, 2007
  9. elbar

    elbar New Member

    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    0
  10. MLeeper

    MLeeper New Member

    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0

    I'm having a similar issue with several Joomla components on my site, http://mlwebtechnologies.x10hosting.com. The backend configurations of those components all give this error: "Parse error: syntax error, unexpected ';', expecting T_FUNCTION . Very unusual since there are multiple components affected. I've also noticed that file rights are not behaving/showing correctly. Everything is showing in the Joomla administrator console as unwriteable and I've made no changes. The JoomlaXplorer component fails to load with this error: "posix_getpwuid() has been disabled for security reasons". Everything was working fine last night. :dunno:

    Please advise!!!
     
  11. eNoyx

    eNoyx Member

    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    Code:
    Parse error: syntax error, unexpected $end in /home/enoyx/public_html/deathnote/modules/mod_paypal_2.6.php on line 119
    Getting this on the frontpage, in the Paypal module, which was working fine until now.
     
    Last edited: Jun 22, 2007
  12. lionheart8

    lionheart8 New Member

    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    the memory problem now
    at http://www.orbit.x10hosting.com/drupal5/ is doing everything to resist being solved.
    I have not been able to see my site load since the 17th. :(
    Whatever changes were made on that day deep in the nite (Berlin local time). ....
    Still hoping...
     
  13. mdm88

    mdm88 New Member

    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    0
    i found a new error from phpBB

     
  14. musoc

    musoc New Member

    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    Ok; hey all again... please help me nut this one out; Please note my gallery was working fine for the last half year until the change over :)
    This is still my error for my Gallery2 application again; (http://musoc.exofire.nt/chevalier)
    _______________________________________
    Error
    Error (ERROR_PLATFORM_FAILURE) :
    • in modules/core/classes/GalleryTemplate.class at line 270 (GalleryCoreApi::error)
    • in modules/core/classes/GalleryTemplate.class at line 200 (GalleryTemplate::_initCompiledTemplateDir)
    • in main.php at line 418 (GalleryTemplate::fetch)
    • in main.php at line 87
    • in main.php at line 80
    • in /home/musoc/public_html/chevalier/main.php at line 3
    _______________________________________
    SO; Reading the support items here;
    http://codex.gallery2.org/Gallery2:FAQ#I_get_a_ERROR_PLATFORM_FAILURE.2C_what_should_I_do.3F
    I am told;
    _______________________________________
    Usually you get either an ERROR_PLATFORM_FAILURE or the upgrade wizard reports that the filesystem permissions are wrong for your storage folder, i.e. it can't write to all files and subfolders in that folder anymore.
    • To fix the problem, you can try the Fix the storage folder (make it writeable) tool in http://example.com/gallery2/lib/support/ on the Filesystem Permissions page. (This tool was added in G2.1.1), older versions don't have it.
    • You can also try to change the permissions to 777 (read & writeable for everyone) with your FTP program. If all fails, please ask in the forum for help such that we can verify that it is indeed a filesystem permissions problem. If it actually is one, you'll have to ask your webhost to change the filesystem permissions recursively for you (e.g. chmod -R 777 g2data).
    • A common issue is:
    Error (ERROR_PLATFORM_FAILURE) :
    in modules/core/classes/GalleryTemplate.class at line 270 (gallerycoreapi::error)
    in modules/core/classes/GalleryTemplate.class at line 200 (gallerytemplate::_initcompiledtemplatedir)
    In that case, if the above suggestions do not help, please try to delete g2data/smarty/templates_c/ folder via FTP or whatever tool you use to upload / manage files of your website.
    • If the problem does not disappear or is reappearing after it has been fixed for a while, please ask your webhost whether there are any scripts that change the owner of the files to the account owner. This could be the culprit since files are not created / managed by your account, but by the webserver application. We also welcome you to consult the Gallery forums for further expert advice.
    So now I need to ask you guys for help; everything else is failing; I can't get the Fix The Storage Folder application to work since it can't seem to get permissions to change at all.
    _______________________________________
    May I please now "ask you guys as my webhost to change the filesystem permissions recursively for me (e.g. chmod -R 777 g2datachevaliergal)".

    And failing that may I also ask if there "are any scripts that change the owner of the files to the account owner. This could be the culprit since files are not created / managed by your account, but by the webserver application"?

    Thanks so much for your help everyone :)

    Tom...
    Edit:
    And now phpinfo() seems to have been disabled today as well I think? Please help --> I can't get support from gallery2 forums without the info thier support package pulls from our server so I know what version of php we have and all that jazz... Thanks! Tom...
     
    Last edited: Jun 22, 2007
  15. eNoyx

    eNoyx Member

    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    You can always CHMOD your storage folder one by one, as I did. I know it's such a pain, but it works ^^
     
  16. musoc

    musoc New Member

    Messages:
    54
    Likes Received:
    0
    Trophy Points:
    0
    God are you serious? That sounds amazingly torturous.. haha...
    I have CuteFTP Pro... is there any other way around it at all?
    And do you really think that'll be the perfect solution or just a long shot?
    Sorry to ask you a million q's eNoyx --> but do you think the other things admin can do might be more feasible and achieve real results?

    Best wishes and thanks so much for your help and time :)

    Tom...
     
  17. eNoyx

    eNoyx Member

    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    16
    The recursive CHMOD would be the better solution, of course. But, if nobody can do it for you (since some SSH is needed to do this, or admin access), it's the same if you go one by one.

    The online FTP software, http://www.net2ftp.com/ , allows recursive chmodding, but due to the huge amount of subfolders that Gallery 2 uses, the script stops in the way and you have to do it in several steps.
    So, at least, you should try the upper level, one folder by one, and if G2 keeps giving the permission error, CHMOD the folder it says. The 'locks' one is specially full of subfolders ;)

    Bye!
     
  18. Aria5

    Aria5 New Member

    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    0
    http://caninecountry.exofire.net

    My include files don't show, my style script doesn't show... Monday I had a prob with permissions but fixed that with Waccoons and Albels help ((not on this forum)) but now its just... egh.
    Edit:
    I had to do that with my oekaki. Luckily it was only 4 folders and about 20 files that needed permissions changed. :happysad:
     
    Last edited: Jun 23, 2007
  19. elbar

    elbar New Member

    Messages:
    245
    Likes Received:
    0
    Trophy Points:
    0
    Not that passage in index of my site, impossible to see it does not recognize index.php to me of index
    Mkportal.
    http://forobar.com.ar

    :dunno:
     
  20. Micro

    Micro Retired staff <i> (11-12-2008)</I>

    Messages:
    1,301
    Likes Received:
    0
    Trophy Points:
    36
    Download SmartFTP (http://www.smartftp.net)

    You can check the "Apply permissions to all file / folders" which will recursively apply them to every folder and file under the selected folder.
     
Thread Status:
Not open for further replies.

Share This Page