Stoli MySQL Issue

Discussion in 'News and Announcements' started by Corey, May 16, 2011.

Thread Status:
Not open for further replies.
  1. Corey

    Corey I Break Things Staff Member

    Messages:
    34,552
    Likes Received:
    181
    Trophy Points:
    63
    The updates the other day seem to have caused an issue with MySQL on Stoli. We are currently investigating. At the moment I have shut down the MySQL server to prevent access while we investigate some files that were changed from the updates.
     
  2. Corey

    Corey I Break Things Staff Member

    Messages:
    34,552
    Likes Received:
    181
    Trophy Points:
    63
    If you're on Stoli and having issues with MySQL please post here what issue you're having.
     
  3. renrabbit

    renrabbit New Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    0
    Mine was having a problem of missing tables, but it is fine right now. Thanks!
     
  4. soupcantheatre296

    soupcantheatre296 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I'm on the Stoli server and I've been having a HUGE problem with my database (I strongly suspect related to the issue you are refering to). I've outline my issue in great detail in this thread: http://x10hosting.com/forums/free-hosting/156576-database-error-re-wordpress-site.html

    I sincerely hope you can get this sorted out as soon as possible - my site has been completely down and innaccessible for 3 days now.

    Thank you very much for your help! Despite this rather unfortunately hiccup, I've been very thankful for your services :)
     
  5. wc3garage82

    wc3garage82 New Member

    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    0
    For my website
    seems that i'm missing a table:

    #1017 - Can't find file: 'mybb_threadviews' (errno: 2)

    at the database's table lists it says:

    mybb_threadviews in use

    thats my issue now
    oh and another one, sometimes, when I try to backup a database, it sometimes says a random Table doesn't exist error
     
  6. martin149

    martin149 New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    I Cannot see any database that i have added to a a user, it said "no databases"
     
  7. rmu1392

    rmu1392 New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0
    I think the only way to resovle this issue is for the user to reinstall there databases from a back up, then delete there old database, thats what i did, now everything is working fine. It's to big an issue for admin to sort out when it can be easily resolved by installing a back up and changing the database name to a new one then reconfiguring config file to point to the new database

    This is my website which hasn't worked for nearly a week and now it's fine, took me 5 mins to fix by doing what I said above,
    http://informationation.x10.bz/


    Thanks
     
  8. stetrii90

    stetrii90 New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    I haven't checked the MySQL database but all of my files in the file manager are gone. Anything in the database won't matter since the only table created was the one I used for learning MySQL and PHP code. But why were all of my files erased? I can easily start over but I want to know that this isn't going to happen again.
     
  9. anoviceyup

    anoviceyup New Member

    Messages:
    21
    Likes Received:
    0
    Trophy Points:
    0
    I'm on Stoli too.

    Although WordPress has no trouble accessing the database, I cannot log into it using phpMyAdmin from Cpanel. Every time I click the phpMyAdmin link in Cpanel, I get a login screen from phpMyAdmin. (It never happened like that before. I'm normally logged in automatically if I click that link.) If I log into phpMyAdmin using my Cpanel username/password, I get an invalid password. If I log into phpMyAdmin using my database username/password, my database is empty.

    But the strange thing is that WordPress is still able to successfully access the database.
     
  10. wc3garage82

    wc3garage82 New Member

    Messages:
    43
    Likes Received:
    0
    Trophy Points:
    0
    about my post earlier, i just re-created the database 'cause the table wasn't that so important

    but after that, i try recounting mybb's statistics (recount & rebuild tool) and it takes time, then after long time of loading, it would give me a 500 internal server error. but the database repair is just working properly
     
  11. denzil

    denzil New Member

    Messages:
    134
    Likes Received:
    3
    Trophy Points:
    0
    I just had some missing tables earlier on (yesterday), but all seems back in order now.
     
  12. ddlmovie

    ddlmovie New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    0
    First one of my websites got listed as a potentially harmful website in google index for no reasons. Their wasnt even any upload activity for several days (usms.co.in). Two days later, files were cleaned out from my wordpress directory. It had a sub directory that wasnot related to wordpress, that also got deleted. When i restored a backup, i found out there was a problem with Mysql. I logged into phpmyadmin, although names of all my databases appeared but none of the tables were appearing. Now my wordpress folder is again cleaned out.
     
  13. jdscdd13

    jdscdd13 New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    For the last 2 days website has been down.
    'Database Error: Unable to connect to the database:Could not connect to MySQL'
    read on the forum about stoli mysql issues so though i'd wait to see if it rectifies itself.

    Just checked the server again, still no access.
    Checked phpMyAdmin and my database has disappeared.
    'No databases associated with this account'
    What do I do now do I start again from scratch, or is there a way to get it back.
    :confused:
     
  14. zeroark

    zeroark New Member

    Messages:
    28
    Likes Received:
    1
    Trophy Points:
    0
    I'm on Stoli. Once I check my databases on Cpanel, they are there (I have two databases) both are 0.00 MB. Then I go and check in phpMyAdmin, I get a "No databases found" there.

    The weird thing about this is that my websites didn't worked from Friday till Monday. (The databases couldn't be found) ... But yesterday they started working normally - even with the errors stated above - So I was just reporting. For now I'm Ok with this, but in some days / weeks I might have to make some changes to the data and, since I can't see the databases, I think I won't be able to do it.

    Thanks in advance guys!
     
  15. rmu1392

    rmu1392 New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    0

    Forget about check or repair in my case they did nothing
    Ok this is what i did, logged into cpanel, went to "MySQL Databases" (not MySQL Databases
    wizard) created a new database, (ie, old one was "jo152" made new one "jo153" to keep
    things simple) then went down the bottom of the page and associated that database with

    my user name in the "Add User To Database" tool. Once that was done i went into "phpMyAdmin"
    and pulled up the new database (ie, "user_jo153" which was empty), then I went to the
    backup database on my computer and change the name of the database file from
    "localhost.sql" to the new name "user_jo153.sql" i then opened that database with Wordpad
    and scrolled down not far from the top until I came to the line:

    CREATE DATABASE `user_jo152` DEFAULT CHARACTER SET latin1 COLLATE latin1_swedish_ci; USE `user_jo152`;
    and deleted it. other wise it will try and create a new database which you dont want it to
    do as you have already created an empty one in the previous step.

    then just above that line you have just deleted is a line that says:
    Database: `user_jo152`
    or what ever your old database is called change that to the new database name in my case
    it was:
    Database: `user_jo153`
    now go back to "phpMyAdmin" and click on 'import" browse to the file we have just finished
    with and upload it, hopefully if you done everything right you should get the green
    writing comformation that everything uploaded correctly,
    now go file manager " Web Root (public_html/www) " and scroll down to "configuration.php"
    make sure the file permissions are set to (644 and not 444) open file with edit, scroll
    down to "var $db = 'user_jo152';" or what ever your old one is called and change the
    database name to the new one in my case it was change from var $db = 'user_jo152'; to
    var $db = 'user_jo153';
    save and check website in my case it fixed it.
     
    Last edited: May 19, 2011
  16. mkmemo6966

    mkmemo6966 New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    i have this error
    [function.mysql-connect]: Access denied for user 'username'@'blah.blah.blah.x10hosting.com' (using password: YES) in /path/page.php on line XX
    and when i log to phpmyadmin it promote mt to put username and password but i don't remember that I've set a user and a pass ....
    is it the same database username and password???
    i hope you'll fix that soon.

    ---------- Post added at 04:01 PM ---------- Previous post was at 03:57 PM ----------

    i have this error
    [function.mysql-connect]: Access denied for user 'username'@'blah.blah.blah.x10hosting.com' (using password: YES) in /path/page.php on line XX
    and when i log to phpmyadmin it promote mt to put username and password but i don't remember that I've set a user and a pass ....
    is it the same database username and password???
    coz i've entered both Cpanel and database username and pass but it return
    "#1045 Cannot log in to the MySQL server"
    i hope you'll fix that soon.
     
  17. mike omar

    mike omar New Member

    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    I have more databases than I am allowed. 4 of 2. I think they are old databases that came back after deleting them.
     
  18. ray45378

    ray45378 New Member

    Messages:
    37
    Likes Received:
    0
    Trophy Points:
    0
    Yes that happened to me, I only had one database. When I finally got back into cPanel there were two. One was an old one that had been deleted...So I just deleted it again.
     
  19. mike omar

    mike omar New Member

    Messages:
    33
    Likes Received:
    0
    Trophy Points:
    0
    Yeah, strange.

    Should we delete them ourselves or will they just go away when the problems are resolved?
     
  20. Interscopia

    Interscopia x10 Caffeine Addict Prime Account

    Messages:
    180
    Likes Received:
    3
    Trophy Points:
    18
    Try & delete them yourself, it can't hurt. :)
     
Thread Status:
Not open for further replies.

Share This Page