They ask me a password for see my image

Discussion in 'Scripts, 3rd Party Apps, and Programming' started by marieroy, Oct 2, 2009.

  1. marieroy

    marieroy New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    First, scuse me for my bad english... I'm from Québec...

    I'm also a newby with the web site.


    I have a problem with my image. When I go on my web site, they ask me my password.

    But I put my image in the Public HTML folder, in the subfolder Image. So I don't understand why...


    Also, if I dont type all the adress, with the "index.php" at the end, the page is the index of the repertoire. How I do for the Index.php be deployed unless typing "index.php"?
    http://maroy.exofire.net/Index.php

    Thank you,

    Marie
     
  2. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    Only if you excuse my non-existant French.



    First, notice what the password request is saying:

    WebDisk? A page shouldn't be requesting something from WebDisk.

    Second look at the code for the image

    You are requesting something via WebDisk. You have to make a normal request.

    Change to:

     
  3. ichwar

    ichwar Community Advocate Community Support

    Messages:
    1,454
    Likes Received:
    7
    Trophy Points:
    0
    I'm going to ask you to paste the contents of your .htaccess file here. :)
     
  4. marieroy

    marieroy New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Thanks a lot, Descalzo.

    It's okay now!

    I tought that the WebDisk was the same thing that the FTP.



    Ichwar, here is the content of the .htaccess file

    # -FrontPage- IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti* order deny,allow deny from all allow from all order deny,allow deny from all AuthName maroy.exofire.net AuthUserFile /home/maroy/public_html/_vti_pvt/service.pwd AuthGroupFile /home/maroy/public_html/_vti_pvt/service.grp Options All


    Oh..... I see the "indexIgnore"... I suppose that it's my error?
    How I do for change this?

    Thank you!

    Marie!
     
  5. ichwar

    ichwar Community Advocate Community Support

    Messages:
    1,454
    Likes Received:
    7
    Trophy Points:
    0
    You need to rename your Index.html to index.html.
     
    Last edited: Oct 2, 2009
  6. marieroy

    marieroy New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    0
    Thank you Ichwar!

    That was my error. I didn't know that it was so stiff!

    I will be more rigorous the next time!


    Merci!

    Marie!
     
  7. ichwar

    ichwar Community Advocate Community Support

    Messages:
    1,454
    Likes Received:
    7
    Trophy Points:
    0
    Just remember that apache (which is the server "language") as well as PHP, are without exception case sensitive. :)
     
    Last edited: Oct 2, 2009
  8. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    Nope.

    It depends on the underlying OS, not on Apache.

    Apache on Windows is not case sensitive.

    And if you add mod_speling on a *nix machine, Apache becomes case insensitive.
     
    Last edited: Oct 2, 2009
  9. ichwar

    ichwar Community Advocate Community Support

    Messages:
    1,454
    Likes Received:
    7
    Trophy Points:
    0
    Ok fine. On all apache servers I've ever used, ( which is a fair amount ) apache and php have ALWAYS been case sensitive. In light of that, it's a good rule to follow. :)
     
  10. xav0989

    xav0989 Community Public Relation Community Support

    Messages:
    4,467
    Likes Received:
    95
    Trophy Points:
    0
    Well, ichwar, a lot of people around here have computer(s) running any version of windows, so don't make assumptions next time :biggrin:!!!!
     

Share This Page