Unable to use any PHP extension in any version

Discussion in 'Free Hosting' started by nation13, Nov 29, 2019.

  1. nation13

    nation13 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    Hello,
    Please help me with following issue please.
    I am utilizing this account since 2013 or 2014. Recently, for new clean installation of WordPress (WP). I started cleaning my account deleted all the databases and there users. Moreover, I deleted all the content in the File Manager, unfortunately Show Hidden Files (dotfiles) was enabled and I accidentally deleted all the content and removed it from the trash too: rather, I checked the skip to move it to trash bin.
    After that every thing is working fine except the PHP extensions e.g. mysqli, PDO, bcmath, json e.t.c. I tried a lot of the available solutions like changing PHP versions, enabling and disabling PHP extension from cpanel but all in vain nothing worked.
    I would be very thankful to working solution or admin can refresh my account so that the PHP extension work again. Currently no data is in the account just testing files so that I can confirm the mysql connection.
    Regards.
     
  2. spacresx

    spacresx Member

    Messages:
    225
    Likes Received:
    4
    Trophy Points:
    18
    have you tried setting your cpanel theme to paper_lantern ?
    (even if it shows as paper_lantern click it again to be sure it is)
    x10hosting made cpanel changes and some things did not work right at first.

    then try software > select php version and choose your php.
    and the settings you want for php.

    You can also provide your website link so others can look.

    as for WordPress (WP) id suggest NOT using the one in the cpanel.
    download a fresh install and upload the files to your account.
    a few have reported issues with the one thats in cpanel.
    (since x10 made cpanel changes)
     
  3. nation13

    nation13 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I tried to change the theme to basic then again paper_lantern then again selected the php version from 5.4 to 7.1 but result still same as mysqli, json, dom and other extension are still not available.
    The base url is https://nationalsavings.x10.mx/ (I included activecollab-probe requirement checker script to check the current situation)
    and WP url is https://nationalsavings.x10.mx/wp/
     
  4. spacresx

    spacresx Member

    Messages:
    225
    Likes Received:
    4
    Trophy Points:
    18
    i have no idea what the
    "activecollab-probe requirement checker script" is,
    but if its not provided by x10hosting i cant help you with that.

    did you try the suggested fresh wordpress install?
    not the one provided in cpanel. as i mentioned ?
     

Share This Page