White Screen (But db working fine)

Discussion in 'Off Topic' started by Bagadonuts, Jul 6, 2016.

  1. Bagadonuts

    Bagadonuts New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Last edited: Jul 6, 2016
  2. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,515
    Likes Received:
    112
    Trophy Points:
    63
  3. Bagadonuts

    Bagadonuts New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much caftpx10; I made that change and then I adjusted the php version to the proper one in the startup.php file and this is the error:
    Warning: require_once(): http:// wrapper is disabled in the server configuration by allow_url_include=0 in /home/gofishma/public_html/index.php on line 21

    Warning: require_once(http://gofishmarketplace.x10host.com/system/startup.php): failed to open stream: no suitable wrapper could be found in /home/gofishma/public_html/index.php on line 21

    Fatal error: require_once(): Failed opening required 'http://gofishmarketplace.x10host.com/system/startup.php' (include_path='.:/opt/alt/php55/usr/share/pear:/opt/alt/php55/usr/share/php') in /home/gofishma/public_html/index.php on line 21


    Here is the code:
    <?php
    // Version
    define('VERSION', '2.0.3.1');

    // Configuration
    if (is_file('config.php')) {
    require_once('config.php');
    }

    // Install
    if (!defined('DIR_APPLICATION')) {
    header('Location: install/index.php');
    exit;
    }

    // VirtualQMOD
    require_once('./vqmod/vqmod.php');
    VQMod::bootup();

    // VQMODDED Startup
    line 21--> require_once(VQMod::modCheck(DIR_SYSTEM . 'startup.php'));

    // Registry
    $registry = new Registry();

    // Loader
    $loader = new Loader($registry);
    $registry->set('load', $loader);

    // Config
    $config = new Config();
    $registry->set('config', $config);

    // Database
    $db = new DB(DB_DRIVER, DB_HOSTNAME, DB_USERNAME, DB_PASSWORD, DB_DATABASE);
    $registry->set('db', $db);

    // Store
    if (isset($_SERVER['HTTPS']) && (($_SERVER['HTTPS'] == 'on') || ($_SERVER['HTTPS'] == '1'))) {
    $store_query = $db->query("SELECT * FROM " . DB_PREFIX . "store WHERE REPLACE(`ssl`, 'www.', '') = '" . $db->escape('https://' . str_replace('www.', '', $_SERVER['HTTP_HOST']) . rtrim(dirname($_SERVER['PHP_SELF']), '/.\\') . '/') . "'");
    } else {
    $store_query = $db->query("SELECT * FROM " . DB_PREFIX . "store WHERE REPLACE(`url`, 'www.', '') = '" . $db->escape('http://' . str_replace('www.', '', $_SERVER['HTTP_HOST']) . rtrim(dirname($_SERVER['PHP_SELF']), '/.\\') . '/') . "'");
    }


    I tried to allow URL include in the php.ini file but there was no line of code for that in the php.ini file. This was there though:
    allow_url_fopen = on;

    Thank you for your help!
     
    Last edited: Jul 6, 2016
  4. Bagadonuts

    Bagadonuts New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    I think it's something to do with the VQMod::bootup();

    (which is above line 21) But I am not sure. I did recently just move the site over from another server, so maybe the problem is in the server configuration somehow?
     
    Last edited: Jul 6, 2016
  5. essellar

    essellar Community Advocate Community Support

    Messages:
    3,295
    Likes Received:
    227
    Trophy Points:
    63
    It is the server configuration, but it's not a "problem", it's a deliberate security decision on the Free Hosting servers. You can only include or require by local path, not URL.
     
  6. Bagadonuts

    Bagadonuts New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Thank you essellar; I adjusted it to this:
    // VQMODDED Startup
    require_once(VQMod::modCheck('./system/startup.php'));

    But now there is no error at all and still a white screen...

    Please help; it is very important that I test this website code to see if the site works with these backup files. I hired a shaky company in India to write the code for my website and they took my $8,000 and are now ignoring me.
     

Share This Page