WordPress Theme Editor redirects to an Error 404 page on my blog (Urgent)

Discussion in 'Free Hosting' started by JustaGirl93, May 3, 2016.

Thread Status:
Not open for further replies.
  1. JustaGirl93

    JustaGirl93 New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Summary:

    1. Background information: Wordpress installed via script installation method. I have installed a custom child theme I bought for the genesis framework. Yes I have both genesis + child theme installed (so I am not missing the framwork)

    2. When I try to edit the custom theme's file/code in the WP Admin - Theme Editor it redirects me to an error 404 page on my blog as soon as I hit "Update File" instead of keeping me on the WP Admin - Theme Editor page. The files that I am trying to update aka the files that get this error are the front_page.php, functions.php and theme-defaults.php

    3. The style.css and the page_landing.php files of the same theme update fine, and will say "File edited successfully" and I am still on the same page in the WP Admin - Theme Editor. All my other Wordpress themes and all of their files are also updating just fine.

    Why do I have this issue? And how do I fix it?
    I thought it was a glitch. So I have deleted the website, re-created it, re-installed the Wordpress script, the genesis framework + custom child theme about 4-5 times already but I get the SAME error/redirection on the SAME custom theme files.

    Photos included:

    1. For the themefiles that work: style.css and page_landing + all theme files for all the OTHER theme I am still in the Wordpress Admin - Theme Editor area and it says file edited successfully.

    2. For the front-page.php, functions.php and theme-defaults.php of that custom made child theme, I get redirected to that Error 404 page on my blog. As you can see the URL in the address bar is also different than the files that do work.
     

    Attached Files:

  2. ajstetson17

    ajstetson17 Member

    Messages:
    56
    Likes Received:
    7
    Trophy Points:
    8
    It sounds like it could be a mod_security issue, where the data being submitted through the editor is triggering a mod_security rule and redirecting you Tina 404 page. If this is the case, @Dead-i usually can modify the rules to eliminate the false positive.
     
  3. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    367
    Trophy Points:
    83
    Hi,

    Mod Security automatically prevents requests that contain some content that looks similar to JavaScript/PHP, because this could potentially be used for web-based injection attacks. While I can disable individual rules for individual accounts, I would rather not risk disabling such a generic rule. Instead, please edit your files manually using cPanel File Manager or FTP, which do not have such restrictions. WordPress have a (brief) article on this under "Editing Files Offline", if that helps.

    Thank you,
     
Thread Status:
Not open for further replies.

Share This Page