Domain name with /wp

Discussion in 'Off Topic' started by bteox10h, Feb 16, 2019.

  1. bteox10h

    bteox10h New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi, I have my own domain name and I want my website to be as bteo.store however i set up wordpress storefront and now when i go to bteo.store, it shows the 'index of bteo.store'.
    My website can only be seen when i type bteo.store/wp
    Is there a way i can move some files or do something so that i can have bteo.store as the main domain name to give my customers?
     
  2. reecehai

    reecehai Member

    Messages:
    44
    Likes Received:
    2
    Trophy Points:
    8
    bteo.store is working fine for me... Maybe just a caching issue?
     
  3. bteox10h

    bteox10h New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi @reecehai , thanks for checking. That really matters :)
    I've spent the last week ironing out the issues with in-depth learning and managed to solve the prevalent issues one by one. Still have a few more to settle before I can smile and relax though!
     
  4. reecehai

    reecehai Member

    Messages:
    44
    Likes Received:
    2
    Trophy Points:
    8
  5. bteox10h

    bteox10h New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    I am using cloudflare and just checked my website through my phone and i do see the green padlock for https.
    But problem is, when im on WooCommerce or editing my store through WP, I will still get the notification that "no SSL certificate detected". Thats where I get confused. I'm not sure if I have to create a TLS certificate. Please see the pictures attached.
     

    Attached Files:

  6. bteox10h

    bteox10h New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    This is the notification I get when im on my wp-admin page of my store.
    I tried adding items to cart and checking out, everything seems secure. I dont know if I should just ignore that notification on wp-admin.
     

    Attached Files:

  7. reecehai

    reecehai Member

    Messages:
    44
    Likes Received:
    2
    Trophy Points:
    8
    I think it's because your site is still accessible via http and not https only.

    In cloudflare under crypto is
    Always Use HTTPS on?

    And

    Automatic HTTPS Rewrites - on?

     
    • Like Like x 1
  8. bteox10h

    bteox10h New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Always Use HTTPS on?
    Its off. Should I turn it on? I remember doing this last week and also changing from WP to https and got locked out of my wp-admin. If this should be turned on, il do it now.
    And

    Automatic HTTPS Rewrites - on?

    Yes, on.
     
  9. reecehai

    reecehai Member

    Messages:
    44
    Likes Received:
    2
    Trophy Points:
    8
    You didn't change the URL inside of wordpress did you? Its an odd system but wordpress internally will stay as http which is ok.

    In cloudflare under 'page rules' create one as per the image i've attached and save. It might take a short time to kick in but the front end of your site should no longer show as http.
     

    Attached Files:

  10. bteox10h

    bteox10h New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Initially i did change in WP but since I was locked out, I changed it back to http in WP.
    I will do as per your attached image.
    Also, do I turn On the Always Use HTTPS on in cloudflare?
     
  11. reecehai

    reecehai Member

    Messages:
    44
    Likes Received:
    2
    Trophy Points:
    8
    Ok don't change anything in wordpress itself or it will break, I would leave it off first, Try the change then if it still allows http:// and doesn't redirect to https then turn it on.. It might take about 10 mins to take effect.
     
    • Like Like x 1
  12. bteox10h

    bteox10h New Member

    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Done! Ive tried using http to see and it gets redirected well to https :)
     
  13. reecehai

    reecehai Member

    Messages:
    44
    Likes Received:
    2
    Trophy Points:
    8

Share This Page