HTTP ERROR 500

Discussion in 'Free Hosting' started by crosstra, Feb 6, 2018.

  1. crosstra

    crosstra New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello. I'm getting the HTTP ERROR 500 error for my website www.crosstrainedmind.com. As far as I can tell, there is no other indication that it is down. I have tried to connect on both IE and Chrome to the same results, as well as tried two different computers, each on a different network. What would you recommend I try next? Thanks.
     
  2. lylex10h

    lylex10h Active Member

    Messages:
    789
    Likes Received:
    53
    Trophy Points:
    28
    Check your .htaccess . If you are not familiar with it, try renaming it to htaccess.txt and see if that makes a difference.
     
  3. crosstra

    crosstra New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    It's the default Wordpress information:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
     
  4. lylex10h

    lylex10h Active Member

    Messages:
    789
    Likes Received:
    53
    Trophy Points:
    28
    Are the permissions on your public_html (or wherever crosstrainedmind.com points to) 755? Did you try renaming the file to htaccess.txt?
     
  5. crosstra

    crosstra New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Made both changes. Same error:

    upload_2018-2-6_16-53-9.png
     
  6. lylex10h

    lylex10h Active Member

    Messages:
    789
    Likes Received:
    53
    Trophy Points:
    28
    Can you try changing your PHP version and seeing if that makes a difference?
    cPanel -> Software and Services box -> Select PHP Version
    I'm starting to run out of ideas. Also try this hello.php file (in hello.zip) and see if that works.
     

    Attached Files:

  7. crosstra

    crosstra New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I was able to access hello.php after uploading it. However, my cPanel looks like the following:

    upload_2018-2-6_23-24-15.png

    As such, I don't see where to try updating anything.
     
  8. crosstra

    crosstra New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Ah ha!

    I was able to enable logging and got this little gem:

    [07-Feb-2018 04:34:33 UTC] PHP Fatal error: Call to undefined function wp_start_scraping_edited_file_errors() in /home/crosstra/public_html/wp-settings.php on line 297

    I commented out the line and am now checking to see what I might update.

    Thanks for all of the help!
     

Share This Page