Litespeed here we come

Discussion in 'News and Announcements' started by Corey, Sep 9, 2011.

Thread Status:
Not open for further replies.
  1. Corey

    Corey I Break Things Staff Member

    Messages:
    34,552
    Likes Received:
    181
    Trophy Points:
    63
    We are in the process of testing out the Litespeed web server for free hosting, more information about Litespeed can be found at their site here: http://litespeedtech.com

    So far it is currently running on Starka and Lotus, if all goes well it will be pushed to the other servers next week. With the change to Litespeed we have the option to possibly support Ruby and some other applications in the future.

    More information regarding this upgrade will be released over the next few weeks as changes are made.
     
    Last edited: Sep 9, 2011
  2. disease74

    disease74 New Member

    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for all the hard work I love the service so far its simple and effective!
     
  3. zer0ne1337

    zer0ne1337 New Member

    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    0
    This awesome! I never expected anyone to offer free LiteSpeed hosting.1 :)
     
  4. FrozenTime

    FrozenTime Member

    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    You all are amazing. Love x10 so much =)
     
  5. engineeringstuff12321

    engineeringstuff12321 New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    but what advantage we will get from this? is there any speed increase
     
  6. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
  7. alexanderbuckland71

    alexanderbuckland71 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Since you started running starka on litespeed ... I have been unable to get into the Rvglobalsoft site builder, I also got errors on the left of my cpanel, after about 30 mins of trying random things it all started working again, although the server is MUCH slower than normal ...is litespeed to blame?
     
  8. vekou

    vekou Member

    Messages:
    196
    Likes Received:
    1
    Trophy Points:
    18
    is the litespeed that you are using a free or enterprise version?
     
  9. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
    Currently it is free hosting only. As far as I know there is no intention to implement this for paid yet, and VPS you need to manually install.

    If you're referring to the version of Litespeed, I don't think Litespeed offers a free version but I'm not sure. If you are referring to enterprise and owned, aren't they exactly the same but one has support included?
     
  10. vekou

    vekou Member

    Messages:
    196
    Likes Received:
    1
    Trophy Points:
    18
    I was referring to the Litespeed version. Apparently, their website lists two version, the Standard and Enterprise, http://litespeedtech.com/litespeed-web-server-editions.html. I was just wondering which version is being used on the free hosting servers, since using the paid will incur additional costs for x10Hosting.
     
  11. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    Not sure if the Standard Edition could handle the x10 set up.
     
  12. Corey

    Corey I Break Things Staff Member

    Messages:
    34,552
    Likes Received:
    181
    Trophy Points:
    63
    It's the enterprise version. Starka will most likely have some random issues over the next few days, we are watching it and fixing them as they come up. Remember that we just dropped in a replacement web server to thousands of accounts so there will be issues. It took us years to perfect our other setup and I expect a week or two to transition all the changes, tweaks, etc that we've made over the years to litespeed. So far it has been working better than expected. Please report issues as they come up though so we can get a fix out. Once this is all working as expected it should be faster than Apache and allow us more flexibility with other features.
     
  13. tondopie

    tondopie New Member

    Messages:
    112
    Likes Received:
    0
    Trophy Points:
    0
    Have you looked into nginx? I use it on my development server. It can probably handle more requests than Litespeed. It's magical.
     
  14. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    And break many websites. Unless there is a workaround for the .htaccess differences.
     
  15. requiem9650

    requiem9650 New Member

    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for the upgrade, though, a stupid question (and more proof I should go lie down and think before I post)

    Is my site supposed to be down orrrrrrrrr... something wrong?
     
  16. Jake

    Jake Developer Contributors

    Messages:
    4,057
    Likes Received:
    5
    Trophy Points:
    0
  17. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
    The issue on Starka has been resolved now, as has the issue on Boru according to the status website. :)
     
  18. fatalill

    fatalill New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    What is the eta on litespeed coming to every server?
     
  19. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    364
    Trophy Points:
    83
    At the moment I believe Litespeed is in testing stages on Starka and Lotus. When everything is all figured out and has been tested to destruction, it might be introduced to the other servers.
     
  20. andrew35133

    andrew35133 New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    0
    S2 on X10Premium is running litespeed and it hasn't had any errors yet :)
     
Thread Status:
Not open for further replies.

Share This Page