SSL via cloudflare not working

Discussion in 'Free Hosting' started by usplayer, Aug 10, 2018.

  1. usplayer

    usplayer New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Hi, i set up my free x10host site and i anabled CF in Cpanel for it but https fails

    https://davesdev.x10host.com/

    so i went to CF and tried to add the site and it told me it already existed but i dont see it anywhere in my CF account.

    So i assume that the CF cpanel function API is suppose to do everything i need it to do without having to manually add it to CF.

    I do see the new CF entries in the dns records in Cpanel but im not sure why https is still not working.

    Here is what FireFox says,
    davesdev.x10host.com uses an invalid security certificate. The certificate is only valid for the following names: *.x10hosting.com, x10hosting.com Error code: SSL_ERROR_BAD_CERT_DOMAIN

    do i need to add the cert to the x10 domain, cpanel does not have the tls option. I do see that one is x10hosting and mine is x10host

    Here is the current dns via Cpanel, as i said there is nothing listed on the CF side in my account and i assume the API from cpanel should take care of that.

    thanks
     

    Attached Files:

    Last edited: Aug 10, 2018
  2. usplayer

    usplayer New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    OK i think i got it, i didnt see the very top of the bar on CF side where i could change sites. Now that i have the x10 site pulled up on CF i should be able to tweek settings and possibly get it working... :)

    Well maybe not... i see with CNAME configs as x10 uses i need to add a txt record via cpanel for the x10 domain.

    Customers who CNAME to Cloudflare need to verify ownership of their domain by adding a TXT record to their DNS.

    To verify your domain, add the above TXT record to your authoritative DNS on the root record, with the subdomain host cloudflare-verify.example.com (replace example.com, of course).

    Leave this TXT record in place. Cloudflare’s automated checker will verify the presence of the TXT record (initially this may take a few hours).

    So i created a txt record:

    cloudflare-verify.davesdev.x10host.com
    14400
    TXT
    data was just a bunch of numbers i chose at random

    did i do that correctly?

     
    Last edited: Aug 10, 2018
  3. usplayer

    usplayer New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    So basicially how do i overcome this :

    This server could not prove that it is davesdev.x10host.com; its security certificate is from *.x10hosting.com. This may be caused by a misconfiguration or an attacker intercepting your connection.

    my site is x10host which is part of x10hosting, and the cert is for x10hosting
     
  4. lylex10h

    lylex10h Active Member

    Messages:
    853
    Likes Received:
    58
    Trophy Points:
    28
    I'm 99.9% sure that you need to use your own domain name (ex. mycooldomain.com) in order to use Cloudflare.
     
  5. eliasyfg

    eliasyfg New Member

    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1

    AFAIK, the SSL will only work if you access your website through www (eg: https://www.mywebsite.x10host.com/ ).

    I once tried it on my website with .x10host.com subdomain, and it showed up with valid SSL, certified by "CloudFlare Inc".
     
  6. lylex10h

    lylex10h Active Member

    Messages:
    853
    Likes Received:
    58
    Trophy Points:
    28

    Attached Files:

  7. macinto3

    macinto3 New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Strange, I recently set it up and it works great. I used .tk domain though.
     
  8. usplayer

    usplayer New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the great info all, ill give it a shot..
     
  9. usplayer

    usplayer New Member

    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    How about for a official dns subdomain mysub.site.com

    i added the cert via cloudflare and it says it covers site.com and *.site.com but when i pull up the domain

    it says...

    The certificate is only valid for the following names: *.x10hosting.com, x10hosting.com

    this site is not a x10 domain, its a registered sub domain

    UPDATE: It might be that i just added the sub domain and the cert is not yet ready... ill wait till tomorrow :)
     
    Last edited: Aug 23, 2018
  10. macinto3

    macinto3 New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Have you fixed the issue?
    Do you use WordPress?
    Can you please create a temporary administrator account for me to take look at why it isn't working?
     

Share This Page