Wordpress Amazon Plug-In Error?

Discussion in 'Scripts, 3rd Party Apps, and Programming' started by chairsba, Jun 30, 2014.

  1. chairsba

    chairsba New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I am running a free hosting WordPress site and was running an Amazon plug-in that was working. I made some changes and now the plug-in throws an error message.

    "Warning: file_get_contents(http://webservices.amazon.com/onca/xml?AWSAccessKeyId= ...... : failed to open stream: HTTP request failed! HTTP/1.1 400 Bad Request in /home/chairsba/public_html/wp-content/plugins/amazon-product-in-a-post-plugin/inc/aws_signed_request.php on line 649"


    And all my searching and working for a solution brings me to this line from the plug-in FAQ.

    "Your hosting accounts php settings do not allow fopen or remote URL fopen calls to the Amazon API. This can be changed in some cases in your php.ini file..."

    It was working before is there any chance this can be solved?

    Thank You.
     
  2. leafypiggy

    leafypiggy Manager of Pens and Office Supplies Staff Member

    Messages:
    3,819
    Likes Received:
    162
    Trophy Points:
    63
    What port are you trying to access?
     
  3. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    So, apparently the request is getting to Amazon, but there is something wrong with it. ie, the ?queryString is missing something or misspelled.

    What happens if you take the URL from the error message and try it in your browser?

    You said you changed something, what?
     

Share This Page