Error 403 when adding to wordpress

Discussion in 'Free Hosting' started by frackque, May 16, 2015.

  1. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Guys, I've been getting this error since mid week. I did not change or install anything on the site and it was only when I went to add a post that I find I get error 403. I loooked then at my resource usage in cpanel and I'm seeing spikes in entry processes at the times I have tried to post to wordpress. The summary tells me this:
    Your site has been limited within the past 24 hours
    You have reached entry processes (number of simultaneously running php and cgi scripts, as well as cron jobs and shell sessions) limit 59 times

    Is it possible to see a log or something to find out what could be causing this? As I say I have not changed anything and the site was working fine the previous time I posted to it about two weeks ago. Any suggestions / hints would be appreciated thanks.
     
  2. adler96

    adler96 Member

    Messages:
    69
    Likes Received:
    2
    Trophy Points:
    8
    You are not alone in this: there is a separate thread about 403 errors, which started about a week ago: https://x10hosting.com/community/threads/403-forbidden.196570/

    On the other hand, very good catch about Cpanel! My site, which is also suffering from the 403 issues, states:

    Your site has been limited within the past 24 hours
    You have reached entry processes (number of simultaneously running php and cgi scripts, as well as cron jobs and shell sessions) limit 10 times​

    Now, I have no idea what that means, or if it is related at all. The issue in my case always appears on the same URLs, independenly of the traffic.
     
  3. adler96

    adler96 Member

    Messages:
    69
    Likes Received:
    2
    Trophy Points:
    8
    Update: I have checked my history, and that issue has been going on for at least the last 30 days. But the 403 error only appeared a few days ago.
     
  4. Skizzerz

    Skizzerz Contributors Staff Member Contributors

    Messages:
    2,929
    Likes Received:
    117
    Trophy Points:
    63
    @frackque: You should be good to go now, let me know if you are still having issues posting.
     
    • Like Like x 1
  5. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Adler96, sorry I only saw your thread after posting my own because the forum search was not working before I posted. I won't be able to check until tomorrow but I'd rather have an explanation than just a good to go from skizzerz. Much as I appreciate it if the issue is resolved I, and anyone else who is having a similar issue would appreciate some explanation as to why this happened and if there is anything we can do to prevent this occurring in the future?
     
  6. Skizzerz

    Skizzerz Contributors Staff Member Contributors

    Messages:
    2,929
    Likes Received:
    117
    Trophy Points:
    63
    Similar to the other thread, there was a mod_security rule tripping you up. I'm going to do a search to see how many other installs are hitting this rule to see if it's something we need to outright disable or if it's fine to keep it on but disable for accounts it is causing False Positives on. Either way, your account should be fine :)
     
    • Informative Informative x 1
  7. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Thanks Skizzerz I hope you are right, can't check until I'm back at a real machine but can you give us a reason why this happened? I'd like to know if there is anything I could do to prevent this from happening in future. Your response is quite like my doc holding a large needle in front of me and saying 'this is the cure'..
     
  8. adler96

    adler96 Member

    Messages:
    69
    Likes Received:
    2
    Trophy Points:
    8
    @Skizzerz : can you check my account as well? I started seeing error 403s on Monday. Thanks.
     
  9. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Ok Thanks Skizzerz for the explanation, much appreciated, maybe something to keep an eye on in the future but also please advise if there is anything we can do to minimise the cause. Thanks again for sorting this out.
     
  10. Skizzerz

    Skizzerz Contributors Staff Member Contributors

    Messages:
    2,929
    Likes Received:
    117
    Trophy Points:
    63
    @adler96 please open a new thread with more info on your specific scenario (e.g. when the errors are occurring -- which pages is it happening on, does it happen when loading the page, when you try to post something, what if you try to post a different thing, etc.).
     
  11. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    hope you get sorted Adler96, let us know.
     
  12. adler96

    adler96 Member

    Messages:
    69
    Likes Received:
    2
    Trophy Points:
    8
  13. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    @Skizzerz , My site is still reacting the same way. I've just tried to update a page in wordpress and I'm given a 403 error page and the changes are not saved on the page. Any more suggestions?
    -Update: It seems I'm no longer hitting the limits as I was in control panel (Thanks) but I still cannot edit / create wordpress pages.
     
    Last edited: May 17, 2015
  14. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    @adler96 - FYI: I found out earlier that I can still edit pages from the Android Wordpress app. Not ideal but better than being unable to modify anything on the website.
     
  15. Skizzerz

    Skizzerz Contributors Staff Member Contributors

    Messages:
    2,929
    Likes Received:
    117
    Trophy Points:
    63
    Can you send me a pm with the contents of the post(s) that are giving you 403 errors (the editor view of the contents, including any HTML markup they have) -- easiest way to do that is to make a post on pastebin.com or a similar site and then send the link to it, that way you don't need to worry about the forums mangling the text.
     
    • Agree Agree x 1
  16. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    OK will try to do that later, (-You mean send you an email to the ryan address above? I can't see another way to pm you on this site) but since you said this I was thinking about it so I tried removing the paypal button code and the page saves fine. All other posts and pages seem to be editable.
    -Are paypal buttons banned by any chance?
     
  17. Skizzerz

    Skizzerz Contributors Staff Member Contributors

    Messages:
    2,929
    Likes Received:
    117
    Trophy Points:
    63
    Email would work, otherwise you can click on my name and then click the "Start a Conversation" link on the lightbox that appears to do a pm in the forum itself. PayPal buttons are not banned, I was just trying to figure out what part of the post was tripping the filter and if there was a way around it that did not involve disabling it (the more filters we disable for an account, the more ways there are for someone malicious to attempt to take over your site and use it to send spam emails, phish passwords, etc.)
     
    • Useful Useful x 1
  18. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Ok, sorry @Skizzerz I saw the conversation option but though it was public:( Will send shortly..
     
  19. frackque

    frackque New Member

    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much @Skizzerz , it seems I had two issues and you have resolved both for me; one by changing a mod_security rule and the second by the advce above - not to use form code with a PayPal button. I have switched to using the PayPal code generated for email use and including the button image link.
    You have solved my issues thank you:D
     

Share This Page